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General Features

Report Layouts

MCReport has two report layouts:
» Text reports, with completely editable contents and manual formatting options.
« Graphical reports, combining a chart and text report in a split window.

This section introduces concepts common to all reports. Concepts unique to text reports and graphical
reports can be found in following sections.

The Right-Click Menu

A report's right-click menu is one of the keysto MCReport's flexibility. Both the report's Local
Profile and tagged datasets can be changed on-the-fly, without the need to regenerate the report.
Reports may also have customisable options accessible via this menu.
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The right-click menu

Note that any changesto areport's Profile or datasets will result in the report being automatically
recalculated. Any manual editing of the report will be lost.

When changing tagged datasets, remember that the report's signature and multi-file restrictions will
till apply.
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Header Sheets

MCReport includes a detailed header sheet with most reports, giving essential details about the
datasets and Profile used to generate the report. Reports may also include an abbreviated header at the
start of the data, or the top of each page. When the details are too large to be compressed (such as
when multiple datasets are included) the abbreviated header will refer to the main header sheet.

MetroCount Traffic Executive
Weekly Vehicle Counts

Weekly\ehicle 620 - English (ENA}

Datasets:

Site: [35291] GRT.NORTHERN HWY SOUTH OF WEST SWAN RD <90km/h>
Direction: 1 - Morth bound, A hit first., Lane: 0

Survey Duration:  13:00 Monday, 20 September 1393 => 14:24 Manday, 27 September 1993
File: D:\Program FilesthetroCount v31B\WsetSamples\UrbanHwy.ecO (Dero FB)
Identifier: C365 Rev 9.02 6/3/1993 (c) 1993 Microcam

Algorithm: Factory default

Data type: Axle sensors - Paired (Clase/Speed/Count)

Profile:

Filter time: 0:00 Tuesday, 21 September 1993 => 0:00 Monday, 27 September 1993
Included classes:  1,2,3,4,5,6,7,8,9,10,11,12,13

Speed range: 0- 200 kmvh

Direction: Notth, East, South, West (bound)

Separation: All- (Headway)

Name: Factory default profile

Scheme: ehicle classification (ARK)

Uniis: - s/, kg, tonne)
In profile: Vehicles = 21438 / 23713 (30.39%,

Sample header sheet

The In Profile line is the number of vehicles or eventsincluded in the calculations of areport, versus
the total number of vehicles or events available in the tagged datasets. Thisis extremely useful for
highlighting the effect of vehicle filter settings, especially when alarge percentage of excluded
vehicles is unexpected. Note that for sequentially generated reports such as the Individual Vehicle or
Custom List reports, the In Profile line appears at the end of the report.

Thefieldsincluded in areport's header sheet can be selected in the Header items tree in the Header
page of the Advanced Profile options.

Profile =)
General | Fomat | Header | Colors | Scheme | Speed | Mass | Separation [ Adjust|
Header items
5@ Tille block | Graphic logo to display above header
1% Show giaphic
9] %, Tile
/1%, Reporthlame Left ~ | Logo position
919, Savelame
~I7] % Show hll path Report file
O Datasets MetroCournt Traffic Executive
V], Site:
. : Attribute: Report name template
[7]%, Direstion 3
]9 Input & Use standard repart name ]
<] Inpt B
]9, Suvey Duration: Allows reports to be eted
)%, Fie: Put headsr on separale page
- {7]1; Idertifer
9% Algoithm
[¥]'%, Data type:
=@ Profile
Filtet time:
Exclusior:
A1, Filter
Included dlasses
], Class Legend
1 oo
Cancel

Changing the Header Sheet format

The header sheet includes an invisible page break to ensure the report data starts on a new page. To
turn this off, toggle the Put header on separate page option.
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Thefirst line of the header sheet title can be changed via the Report title option. Thisis commonly
set to the name of a company, council or county.

MetroCount Surveys

Weekly gCaunts

WeeklyVehicle-138 .. English (ENA)

Datasets:

Site: [35291] GRT.NORTHERN HWY SOUTH OF WEST SWAN RD <90km/h>
Direction: 1 - North bound, A hit first., Lane: 0

Survey Duration:  13.00 Monday, 20 September 1993 => 14:24 Monday, 27 September 1993
File: D:\Program Files\MetraCount v31E\UsenSamplesiUrbanHuwy. ec (Demo FE)
Identifier: 355 Rev 9.02 B/3/1893 () 1293 Microcom

Algorithm: Factory default

Data type: Axle sensors - Paired (Class/Speed/Count)

Profile:

Filter time: 13:00 Monday, 20 September 1993 => 14:24 Monday, 27 September 1993
Included classes:  1,2,3,4,56,7,8,9,10,11,12,13

Speed range: 0- 161 kmsh

Direction: Morth, East, South, West (hound)

Separation: All - (Headway)

Name: Factory default profile

Scheme: ‘ehicle classification (ARX)

Units: Metric (reter, kilometer, m/s, km/h, kg, tonne)

In profile: Vehicles = 23717 / 23718 (100.00%)

Changing the Header Sheet title

A company logo can also be added to the top of the Header Sheet in the form of a bitmap image. This
is specified in the Graphic logo to display above header option, and enabled with the Show graphic
option in the Header items tree.

The tab position between header sheet labels and datais adjustable, to cater for changesin font size.
Simply right-click in areport and select Tabs, then click the mouse at the desired location. This can
also be set using the Tab Position option in the Format page of areport's Advanced Profile options.

Report Name

Each report generated by M CReport has a unique Report Name, which appears in the report's title bar
and header details, and is the suggested filename when saving reports. By default thisisa
combination of an abbreviation of the report type, and an incrementing serial number, such as
WeeklyVehicle-1. The report serial number can be reset at any point by selecting Tools » Settings
from MCReport's main menu, and changing the Next report index option. The Increment report index
on recalculate option causes the serial number to increment whenever areport is recalculated, such
as editing a report's Profile or tagged datasets.

Changing report serial number options
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The format of the Report Name can be changed in the Header page of the Advanced Profile options.
Unchecking the Use standard report name option enables the Report name template. Thisisa
comma separated list of fields, which can be selected from the menu button next to the template.
Fixed strings can be added inside double-quotes. The incrementing report serial number will be
automatically appended to the end of the generated name.

Feport name template
o SITE." - " DATATIME " - " REPNAME

[ Use standard report name >

Changing the report name format

Page Setup

MCReport uses the page size of the currently selected printer to generate reports. The page
orientation (portrait or landscape) is automatically selected based on the type of report being
generated.

The automatic page orientation can be overridden at any time by using the Page orientation optionin
Format page of areport's Advanced Profile options.

The default page margins are set in MCReport's Global Settings, accessed by selecting Tools »
Settings from M CReport's main menu. Margins may be set independently for portrait and landscape
pages. Existing reports will need to be recalculated for the global page margins to take effect.

Flinter margins for portiait pages [mm]
Lefi=10, Top=10, Right=10. Battom=10 [

Piinter margins for landscape pages [mm)
Leh=10, Top=10, Right=10, Eottam=10 C]

Setting default page margins
Page margins may also be set locally in areport, by right-clicking areport and selecting Page setup.

Report Header / Footer

The default page header of reports includes the Report Name and page number, right-aligned.

The Format page of areport's Advanced Profile options includes a Printer header and Printer footer
option for adding asingle line of left-aligned text to the top and bottom of each page.

The tokens <DATE> and <TIME> may be used to insert the current date and time. The operating
system’s current long date and time format will be used.
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Text Reports

Editing
All text reports have fundamental word-processing properties:
» Text iscompletely editable.
* Fonts and colours may be changed.

 Objects, such asimages can be inserted.
» Text can be copied into other programs.

The font used in areport can be set viathe Report font option in the Format page of the report's
Advanced Profile options. MCReport uses a non-proportional font (such as Courier) to construct
columnsin tables, so they will be unaffected by this option.

Font and colour can be changed locally in areport by selecting a block of text, right-clicking and
selecting Typeface from the pop-up menu. Thisis useful for manually highlighting certain figuresin
areport.

The normal view of areport is a continuous stream of text. MCReport automatically inserts hidden
page break characters at appropriate places, such as the end of the Header Sheet. Manual page breaks
may be inserted into areport at the cursor, by right-clicking and selecting Page break from the
pop-up menu. Use the Print Preview to view how areport will be paginated when printed.

Note: Remember that any manual editing of a report will be lost when a report isrecalculated. A
A report is automatically recal culated when any changes are made to the report's Local Profile or
tagged datasets.

Saving

Text reports can be saved by selecting File » Save report as from MCReport's main menu. Reports
can be saved in Rich Text Format (RTF), which includes all the font and formatting information, or
plain text (TXT).

The Save file dialog always defaults to the Folder for report output option in MCReport's Global
Settings, accessible by selecting Tools » Settings from M CReport's main menu.
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Zooming

Text reports can be zoomed on-screen, without affecting the actual font size or printed output. Simply
click the Zoom button on MCReport's main toolbar, and select the desired zoom level. Note that only

azoom level of Actual Size will display apage outline. For atrue indication of printed output, use the
Print Preview.

¥ MCReport - WeeklyVehicle-1] @E@
File Edit View Graph Tools Window Help - [=]x
HaR Eixum da8p | ssmnsRl
50%
B weeldyvehicie-1
‘eeklyVeticle .
0% h
MetroCount Tr: oy ]
Weekly Vehi .
Actual Size
WeeklyVehicle-1 - English (ENA) 110% %
120%
Datasets: N
Site: [35291] GRT.NORTHERN HWY SOUTH 150% 0km/h>
Direction: 1 - North bound, A it first. Lane: 0 200%
Survey Duration: 13:00 Monday, 20 Sey ber 1993 => Torzrmromay: | ber 1993
File: UrbznHwy.ecO (Demo FB)
Identifier: C355 Rev 9.02 B/3/1993 [c) 1993 Microcom
Algorithm: Factory default
Data type: Avle sensors - Paired (Class/Speed/Count) -
<7 m, »
Ready [ LY

Zooming a text report
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Graphical Reports
Split Window

MCReport displays charts and graphs in a unique dual-pane window, with a chart in one pane, and a
text report in the other. For reports grouped into the Charts category in the Report Vortex, the chart is
presented on the left, with the report's Header Sheet on the right. The Custom List report presents a
chart on theright.
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File Edit View Graph Tools Window Help RER
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aw Copy Direction: 2- East bound, & hit first. Lane: 1
2 Survey Duration: 1232 Thursday, 12 July 2007 == 1544 Fridiay, 20 July 2007
Page setup... File: GFF Tunnel Eastbound20.uI2007 EC1 (Plus)
Identifier: 2125088 MCS7-X20 (S)MetroCount D1 NS
Algorithm: Factory default
Data type: Axle sensors - Paired (Class/SpeediCourt)
Profile:
Filter time: 00:00 Friday, 13 July 2007 => 00:00 Friday, 20 July 2007
Included classes: 1,2,3,4,5,6,7,8,9,10,11,12,13
Speed range: 0- 200 kimih
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Split-window graphical report

The left pane is always the primary pane. Its right-click menu contains access to the Local Profile,
included datasets, and report properties. The secondary pane's right-click menu contains the other
usual functions.

The blue MetroCount bar at the top indicates the currently active pane. Certain functions, such as
zooming, can relate to either pane, so only the active pane will be affected. A pane is made active by
clicking anywhere within its region.

Zooming

The default zoom level for agraphical report is fit-to-window, which will maximise the size of the
graph for its pane. Moving the splitter bar to one side will dedicate the entire window to the graph.

The zoom level may also be set to afixed percentage. For values larger than 100%, the scroll bars can
be used to move around the report.

For finer resolution in the data itself without changing the size of the report, consider changing the
Display Span or Integration Time.
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Rendering

Many of the graphical reports have multiple rendering options. Reports generally default to the most

appropriate rendering option, however experimenting with the available options may give better
results for a given application.
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Same report showing different renderings

To change the rendering of a graphical report, activate its pane, and select Graph » Rendering from
MCReport's main menu. The available rendering options will vary depending on the type of report.

The line-thickness used to draw a graph can also be changed in the Format page of the Advanced
Profile options. Thickness can be set independently for on-screen viewing and printing. In general,

one-pixel thicknessis fine for on-screen viewing, however thicker lines may be required for the
higher resolution of printers.

Graph ine [pels]

[2 =]soeen Finter

Graph avis [pivels)

e |- Fina

Changing graph line thickness
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Colours

Almost every colour used in agraphical report can be customised viathe Colours page of the
Advanced Profile options. To change a colour, select it from the list on the left, and use the red, green
and blue sliders. The Gustom button will display the standard Windows colour-picker.
The general groups of colours are;

 Class- used for class and speed bins.

e Trace- primary colours used by most reports.

« Limit - used for horizontal markers such as speed limits, and vertical markers such as
percentiles.

* Glide - used by density plots.
 Phase - used by Phase reports.

Profile ===

General | Foimat [ Header| Colors | Scheme | Speed | Mass [ Separation | Adjust |

In some chatts, properties are represented by color. These colors can be changed
Class28 nso

I Traced 135 Green

Lint1 189 | Blus

[ ":m‘“' Lock RGB sliders together

GraphGiid

Il Graphiegend
GraphMarker
GraphBackground
GraphShadow
fliden

= | [ Print white

Default Custom..

Customising report colours

Vertical Scale

There are several options for calculating the vertical scale of agraph. Graphical reports default to the
most appropriate method for the type of report. An appropriate number of tick-marks will be
automatically selected.

To change the vertical scale of agraphical report, activate its pane, and select Graph » Vert. Scale
from MCReport's main menu. The available options will vary depending on the type of report.

Option Description
Auto Maximum value of the y-axis will be set to the peak data value.

Maximum value of the y-axis will be set to the next integer power above the
Integer power  |peak datavalue. For example, for a peak of 390, the maximum y-axis value will
be 400. For 8421, the maximum y-axis value will be 9000, and so on.

Maximum value of the y-axis will be set to the next 1, 2 or 5 integer power
above the peak datavalue. That is, 1, 2, 5, 10, 20, 50, 100, 200, 500, and so on.

A dialog box will be displayed, where the y-axis minimum and maximum
values can be entered.

125 power

Custom
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Crosshairs and Markers

Time-based plots can be inspected with a pair of crosshairs to examine points of interest. The
crosshairs are activated by clicking on the grey bar at the top of the report grid, and dragging across
the report. Asthe crosshairs are moved, the current coordinates are displayed next to the pointer.

MetroCount
Vehicle Flow

VehiclaFlove5 (Metric) ite: GFF Tunnel Eastbound.1E

Dessription: G mer Freeway Tunnel Easthound s80km/hz

Filter time: 00:00 Friday, 13 July 2007 => 00:00 Friday, 20 July 2007

Filter: CIs(123 4587 &9 10 11 12 13 ) DitNESW) Sp(0,200) He adway(>0)
Scheme: Vehicle dlassification (AR

< 00:00 Friday, 12 July 2007 (Day) hfarker 11:1% Wednesday, 48 July 2007
|l n
7y il
718 11 il [ [ !
=0
| { o
I i \
:
Bl R L\ \ } F \\} \
““'f \/ \ \/ \’ o
T
D000 Fri DDDD‘ Sat DDDD‘ Sun DDDD‘Mon DDDD‘ Tue DDDD‘Wed DDDD‘ Thu 0000 Fri

Using the crosshairs on a graphical report

The crosshairs are also used to place a marker on the graph. When the mouse button is released, a
vertical marker will be placed at that point. The location of the marker is specified on the top right of
the graph. The marker is primarily used for changing the Display Span of a graph.

To clear the marker, simply double-click the grey bar at the top.

Display Span

The Display Span is the subset of the available data currently shown by atime-based plot. By defaullt,
time-based plots are scaled to display the entire data time span. The Display Span may aso be
changed to aweek, day, or hour.
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Example of Display Span set to a week, and a day, for the same report

©2008 MetroCount® - MTE User Manual - Report Fundamentals 10



Changing the Display Span requires a marker to be placed at the point on a graph where the new
Display Span will start. The new Display Span will actually start on the boundary to the left of the
marker. So, for either aweek or aday, the marker can be placed anywhere in the day where the new
Display Spanisrequired to start. For an hour, the marker may be placed anywhere within the desired
hour.

Once the marker has been placed, the desired Display Span can be selected by clicking the Span
button on M CReport's graph toolbar, and selecting from the pop-up menu. The new Display Span
will automatically appear. To step backwards and forwards through the data at intervals of the
Display Span, use the Back and Forward buttons also on the graph toolbar.

The Display Span can be set to start precisely at the marker location by holding down the Ctrl key
when selecting the Display Span from the graph toolbar. Note that this may result in odd times for the
tick marks on the x-axis. To set the marker with greater precision, hold down the Ctrl key when
dragging the crosshairs.

Integration Time

The Integration Time of atime-based plot determines the period of data used to calculate a point on
the graph. For example, a Vehicle Flow graph with an Integration Time of one hour will place one
point per hour of total vehicles.

The Integration Time is closely related to the Display Span. For instance, with a Display Span of a
day, an Integration Time of an hour will give 24 points on the graph. An Integration Time of 10
minutes on the same Display Span will give 144 points, showing much more detail.

Ft MCReport - VehicleFlow-6, e

File Edit Wiew Graph Tools Window Help

HER Bsau® 80 2E0aa Y=

Example of smaller integration time providing more resolution

The Integration Time for a time-based plot can be changed by clicking on the Integration Time button
on MCReport's graph toolbar, and selecting from the pop-up menu. The graph will automatically
redraw with the new Integration Time.

Note that when using a smaller Integration Time the vertical size of the graph will change since fewer
vehicles areintegrated into each point. Also, selecting asmall Integration Time relative to the
Display Span may result in an unreasonable number of points to be plotted. In this case a message
will be displayed, suggesting alarger Integration Time.
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Printing

Printing split-window reports requires two print operations. Selecting File » Print from MCReport's
main menu will only print the currently active pane, indicated by the blue MetroCount bar at the top.
To activate the other pane, click anywhere within its window.

Saving

Graphical reports can be saved as vector-based Enhanced Metafiles (EMF) or as a bitmap image
(BMP). To save agraphical report, select File » Save report as from MCReport's main menu.
Remember that the graph must be the active pane, indicated by the blue MetroCount bar at the top.

The output format is determined by the Save as type drop-down list in the Save dialog box. Note that
the Save dialog always defaults to the Folder for report output option in MCReport's Global Settings,
accessible by selecting Tools » Settings from MCReport's main menu.

Enhanced Metéfiles are a vector-based format, making them ideal for inserting graphs into other
documents. When an Enhanced Metéfile is scaled, everything is redrawn at the new size, producing a
high-quality image. Thefileitself is normally very small.

Bitmaps are more widely supported by other software, however they have an inherent size, and
rescaling them can often produce unsatisfactory quality. When saving a bitmap, MCReport displays a
dialog box where the dimensions of the image can be set. The required size will depend on the
intended use of the image. Only the width needs to be set, so that the correct aspect ratio is
maintained. Bitmap files are generally much larger than the equivalent metafile.

Save bitmap
Size

Kpiels Y piels

1000 703

Est. size (bytes]
2612000

Setting the output size of a hitmap

A graphical report can aso be transferred to another application using copy-and-paste. Simply
right-click on a graph, and select Copy from the pop-up menu. The graph will be pasted as an
Enhanced Metéfile if the target application supportsit. Otherwise the graph will be pasted as a bitmap
at the size shown on screen.
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Report Cloning

Report Cloning is an extremely efficient way to rapidly generate a group of reports. Cloning an active
report automatically generates a new report of the same type, with the same datasets and an identical
Profile. The new report's Profile or datasets can then be easily changed viathe right-click menu. To
clone the currently active report, simply click the Clone report button on MCReport's main toolbar.

# MCReport - ClassMatrix-18 [ i |
File Edit View Graph Tools Window Help
HESR BExnzd J8p 2esnea em
a | J .
Clone report

Lo = e ———
B Classiatric-12 [E=R[EcE =< ClassMatrix-13 [=l[@]=]

Class Spesd Matrix

Cloning a report

Changing areport's datasets via the right-click menu is the fastest way to process a group of datasets.
Load as many datasets as possible into the File Management List, then step through them viathe
Datasets option in areport's right-click menu, printing or saving for each iteration.

Report cloning makes common tasks, such as extracting each direction from bidirectional data, even
more efficient. For example, generate areport filtered for the primary direction, cloneit, then
right-click and change the Local Profile to the secondary direction. Tile the reports on-screen, then
apply the dataset swapping method described above for each report.

Another common task is comparing datasets, and it isimportant to start with an identical Profile,
especialy the vehiclefilter settings. The simplest way to achieve thisisto clone an existing report,
right-click the new report and change the Datasets. This is much faster and more reliable than
generating two reports viathe Report Wizard.

auto-wrap options (such as aligned hours or aligned days) is highly recommended. This ensures the

2 Note: Remember when toggling datasets on an existing report, using one of the Profile's time filter
start and end times will be automatically recalculated for the new datasets.
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Report Assemblies

Report Assemblies are afeature in MCReport for automatically regenerating an active report. Saving
areport as an assembly creates a file with references to everything required to regenerate the report,
including:

¢ Thetagged datasets.

e Theloca Profile.

« Algorithm settings.

e Custom List properties.

When an Assembly is loaded, the referenced datasets are loaded into the File Management List, and a
new copy of the original report is generated - all without interacting with the Report Wizard.

Report Assemblies have a number of important uses:
* Saving the source files to recreate an exact report for future reference, rather than just the report
output.
» Grouping source files together for copying to another user, so that they may generate the same
report.
« Asastarting point for regularly generated reports, whereby a group of datasets can be rapidly
processed by swapping datasets via the right-click menu.

Assembly Load and Save functions can be found in MCReport's File menu. Selecting File » Save
assembly will save the currently active report. MCReport initially defaults to the Assembly folder
under MTE'sworking folder location.

Report state
Report assembly
Current report state can be seen here.
& Weeklpehicle-20
-G Datasets
| B 35291
24 Flle = C:\Users\MTE Diemo User\D: St TE 3
- B, Algorithm = Factory default
2 Input =1
2, InputB =10
(=& Prafile
H 2} Friendly Mame = MCReport
2 File = C:\UserstMTE Demo UsetDiocuments\MetioCountMTE 3 18\ oftware\MCFiepott i
[+-{3 Paiameters
D
Make a new copy of data files
Make a new copy of curtent Profis and Algorithms

Saving a report Assembly

Saving areport Assembly creates atext file with a .stx extension. By default, references to datasets,
Profiles and other resources will have absolute paths. This means when loading an Assembly, it
expectsto find al filesin their original location.

There are two options when saving an Assembly - to copy datasets, and other support files, to the
same folder as the Assembly file. With these options checked, file references will have arelative
path, and can therefore be copied around as a group, even to another PC.
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