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Overview

Site Lists provide an excellent means of managing the process of collecting data. Using the familiar
RSU setup dialog box, site setup information can be compiled into associated lists. Field setup then
only requires connection to a RSU and selection of asite from a Site List. This removes the need for
any manual entry in the field, greatly improving efficiency and accuracy of setup, especially with
Pocket PCs.

Site Lists are created using MCSetup, and can be used in either MCSetL ite or MCSetup. Site Lists
are stored in a simple comma-delimited text file, so they can also be created and edited using a
spreadsheet program.
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MCSetLite with a Site List loaded
M CSetup supports afew advanced Site List features not supported by MCSetL ite, including:
» Maps based on bitmap images, with support for common compressed bitmap images.

« Checklist feature for tracking sites that have been setup, and unloaded.
 Site List usage enforcement, to force RSUs to be setup from a Site List.

Note:

& A SteList window in MCSetup is split into two panes, called the List pane and the Map pane. Most
Ste List operations are performed by right-clicking in one of the panes. Each pane has a different
menu.
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Site List with map in MCSetup - note the right-click menu

©2009 MetroCount® - MTE User Manual - Ste Lists



Site List Construction

Creating Site Lists

Newly created Site Lists are stored in the folder specified in MCSetup's Preferences. The default
location isthe User \ Sites folder located where MTE isinstalled.

A single Site List may contain thousands of sites, however small groups of related sites per Site List
is much more practical.

To create a new Site List

1
2.
3.

In MCSetup, select File » New Site List.

In the New Site List file box, enter afilename.

Click the Save button and an empty Site List will be displayed.
Existing Site Lists are opened by selecting File » Open sites.
When a Site List is closed, MCSetup will ask to save any changes.

Editing Sites

Adding sitesto a Site List uses the same dialog box used for RSU setup. The default setup parameters
used for the new site can be copied from an existing site, or copied from the header of a RSU.

To add a new site to a Site List
1. Right-click inaSiteList'slist pane, and select New site.

Right-click on an existing site to use its parameters as a starting point.

To create a new site from aRSU that has been manually setup, check the Get initial settings
from Roadside Unit option.

Hew site list entry.
MNew site entry

Optionally copy from R oadside unit

The initial values for this new site item can be read from a Roadside Unit directly. Check.
the box below to enable this feature.

[] Geet intial settings from Roadside Unit

%% ([ Concel ] [ e ]

Optionally copy setup parameters from a RSU
Click the Next button to display the setup dialog box.
Enter the setup parameters per normal RSU setup.
Start times such as Next hour or Next day will be automatically calculated at thetimeaRSU is
setup.
When done, click the 0K button.
Again per normal setup, each parameter will be range-checked, and warnings displayed if
necessary.
The site'sicon indicates the type of Sensor Layout selected.
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Icon Description

e Site uses Classifier Layout.
Site uses Count Layout.

aE To edit an existing site
" 1. Right-click on an existing site, and select Edit site.
2. Edit asrequired, and click OK.
To display aread-only summary of asite, simply double-click.

Site properties 3]

01-0

welo ]
Latitude |-31.924628 Lang, |115.784872
Initials Spacing | 1000 mm - 3t 3.4 in

Direction & |5 - South bound 43E, North bound B34, | |1n | Db [ms]

Site number - Lane

Direction B |D - Unuzed or unknown, | |‘ID | DiebE [ms)

Type |Axle sensors - Paired [Class, Speed. E0u|

Diescription |Tuscany ‘way - M of Empire Ave |

Start time ||rnrnedic‘-te|}I |

[ Ok ] [ Cancel ]

Displaying all site parameters

oﬁ To change the start time for a group of sites
g 1. InaSiteList'slist pane, Shift or Ctrl select a group of sites.
2. Right-click on one of the selected sites, and select Set times.
3. Confirm changing the selected sites' start time by clicking Yes.
4. Inthe Roadside Unit Start Time dialog box, select one of the automatically calculated start
times. Remember, the actual time will not be calculated until a RSU is setup.

Roadside Unit Start Time 3]

Set the time for the Roadside Unit to start. The unit can
be deferred for up to ten days.

Start tirne

Start on next day

10:04 Thursday, 18 Movember 2004
Start immediatel
Start on hext hour

<

Start on next day k
Start nest Monday
Start next Saturday =

Setting the start time for a group of sites
5. Click OK to apply the new start times.

Spreadsheet Editing

Site Lists comma-separated-values (CSV) format has been designed to provide maximum
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compatibility with spreadsheet programs. Importing, editing and exporting a Site List through a
spreadsheet program should be a seamless process.

Thefirst column on each row indicates the row type. METAMAP and MAP are used for including map
files, DOC for comments, and SITE for each site. For Site Lists created by M CSetup, a comment row
isincluded above the site rows to form the column headings when imported into a spreadsheet.

METAMAP ,perth.upz

MAP,Churchlands.npz

MAP  Mtlawley.upz

Doc,5ite, Attrib,Init,Desc,Ln,Dird,DirE,Mode, State, Spac, 5trtTo,Debd , DebE, Lat, Long,
SITE,01,Stirling, RPN, Tuscany Way - N of Empire Ave,0,5,0,0,1,1000,0,10,10,-31.924828,115, 764872
SITE,02,5tirling, RPN, Tuscany Way - § of Dolomite Court,0,5,0,1,1,1000,0,10,10,-31.922364,115. 766673
$ITE,03,5tirling, RPN, Tuscany Way - § of Memory Place,0,5,0,2,1,1000,0,10,10,-31,920731,115. 786514

Site List CSV format

Each column must adhere to the normal restrictions for that parameter. The following tableisa

quick-reference.

Column

Description

Site & Attrib

Site & Attribute - maximum 20 characters.

Init

Operator Initials - maximum 3 characters.

Desc

Site Description - maximum 70 characters.

Ln

Lane Number - number less than 16.

DirA & DirB

Directions A and B - for Classifier Layout use A only and leave B as zero.
* 0- Unused or unknown.
e 1- Northbound, A hit first.
» 2 - East bound, A hit first.
» 3- South bound, A hit first.
e 4-West bound, A hit first.
» 5- South bound A>B, North bound B>A.
* 6- West bound A>B, East bound B>A.
7 - North bound A>B, South bound B>A.
» 8- East bound A>B, West bound B>A.

Mode

Sensor Layout
* 0- Axle sensors - Paired (Class, Speed, Count)
» 1- Axle sensors - Separate (Count)
e 2- Axle sensors - Split (Count)
» 3- Vehicle sensors - Separate (Count)

State

Checklist state (MCSetup only).
* O0- Nodstate.
o 1- Site setup.
2 - Site unloaded.
e 3- Site unloaded and stopped.

Spac

Spacing - must be entered in millimetres (mm). Range is 200 - 3050mm.

StrtTm

Start Time.
o 0- Start immediately.
e 1 - Start next hour.
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Column Description

* 2 - Start next day.
* 3- Start next Monday.
e 4 - Start next Saturday.

Debounce for A and B Sensor - in milliseconds (ms). Recommended is 30 for

DebA & DebB single lane, 10 for multiple lanes.

Lat & Long Latitude and Longitude - in degrees. South and West are negative.
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Site List Usage

RSU Setup from a Site List

Using a Site List to setup a RSU is the same as the normal setup process, except the setup parameters

are derived from the Site List, rather than manual entry.

2]
‘." 1.

To setup a RSU from a Site List with MCSetLite
Open a Site List by selecting Tools » Open Site List from MCSetLite's menu button. Browse

for and select a Site List, and tap the 0K button.

2. Select asite by tapping it.

> w

5. The standard setup dialog box is now displayed with the setup parameters from the selected

With aRSU connected, tap the Setup button.
Tap OK to use the selected site. Tapping Cancel will proceed with anormal setup.

®
Setup Roadside Unit with Site

List itern?

Select 'Cancel' for manual setup,

Confirming Site List use

site. Edit any parameters if necessary.

The Lock Site List option in MCSetLite's Preferences will prevent editing setup parameters at
this point. Thisfeature is to discourage users from changing settings away from those specified

in the Site List.

¢ ZZIMCSetLite

P o oz 205

¢ ZZIMCSetLite

P o oz 206

L L

Parameter | Yalue Parameter | Yalue

El site o1 [ site T}

El Lane g E Lane oo

El attribute Skirling [ attribute Stirling

[El sensor La... Axle sensors - Paired (Class/sd | | Sensor La...  Axle sensors - Paired (Class/Sq
El pirection & | 5 - South bound A=B, Morth b [ Direction & 5 - South bound A>E, Morth b
El pebounce  A=10ms, E=10ms [ pebounce | A=10ms, B=10ms

E Cperatar RPM E Operator RPN

El spacing 1000 mm - 3 ft 3.4 in [ spacing 1000 mm - 3 ft 3.4 in

El start Immediately [ start Immediately

E Description  Tuscany Way - N of Empire Av] E Description | Tuscany Way - N of Empire Ay
4 ] | D 4 ] | [»

E|A

E|A

RSU setup from Site List - normal and locked.
6. Tap the OK button to proceed with the setup.
7. Check the RSU's status to confirm the setup.
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oE To setup a RSU from a Site List with MCSetup
v
v

1. OpenaSiteList by selecting File » Open sites . Browse for and select a Site List, and click the
Open button.

M CSetup can have more than one Site List open at the same time.
2. Select asite.
With aRSU connected, click the Setup button.

4. The selected site's setup parameters will be displayed in aread-only form. Confirm the details
and click OK to proceed with the setup.

w

Setup (3]

Site number - Lane

01-0
Site |01 Attribute | Stirling Lane |0
Latitude | -31.924823 Long. |115.784872
Iritials RPN Spacing | 1000 mm - 3 ft 3.4 in
Direction & |5 - South bound A>B, North bound BxA. | |10 Debd [ms]
Direction B |0 - Unuzed or unknown, 10 DiebE [ms)

Type |Axle sensors - Paired (Class, Speed, Cou
Diescription | Tuscany Way - N of Empire Ave

Start time |Next Hour

[ Ok ] [ Cancel ]

Confirmation of site setup parameters
5. Check the RSU's status to confirm the setup.

RSU Unload from a Site List

When thereis a Site List open in MCSetup, the Unload procedure is slightly different. MCSetup will
retrieve the RSU's header, and attempt to match it to an item in the currently active Site List. Thisis
to support MCSetup's Data Collection Checklist feature.

To unload datafor asite that does not exist in aSite Ligt, firstly close all open Site Lists, and then
proceed with the Unload.

oE To unload data using a Site List
v » 1. Open the Site List that contains the site that the connected RSU was setup with.
2. Click the Unload button on MCSetup's main toolbar.

3. MCSetup will locate the site in the Site List and start the Unload procedure.
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Maps (MCSetup)

Overview

A map in MCSetup consists of aMap File, which uses a.mpz file extension. Thisfile contains a
pointer to the location of the map's bitmap image, and additional information about the map, such as
latitude and longitude.

A Site List can have several attached maps, with sites distributed across them. Also, asingle map can
be shared amongst several Site Lists.

Each Site List can also have a map designated as the Metamap. Thisis usually alow detail map that
encompasses each of a group of smaller, high detail maps.

Preparing Maps

Site Lists support maps in the form of bitmap images, including common compressed bitmap
formats, such as JPEG. Such images can be sourced from many locations, including local street
directories, or exported from a vector-based mapping system.

Suitable bitmap images should contain sufficient detail to allow sites to be placed with reasonable
accuracy, based on the screen size where M CSetup will be used. Remember that multiple maps can
be associated with each Site List, as well as alow-detail Metamap.

In order to use a bitmap image, the corresponding Map File must first be generated. A Map File
contains a pointer to the bitmap image for the map, and the latitude and longitude of the bounding
rectangle of the map. The Map File is then attached to Site Lists as required.

Note that when generating a Map File, the latitude of the top and bottom boundaries, and the
longitude of the left and right boundaries of the image will be beneficial. These coordinates are used
for anumber of purposes:

» Assigning coordinates to sites placed on amap.

» Locating sites on amap.

« Displaying the bounding rectangles of each attached map on the Metamap.

 Locating and placing sites using a GPS unit.
If the bounding coordinate information is not available, it is still possible to use mapsin Site Lists,
however the functionality listed above may be limited. Alternatively, for adjoining maps, simply

make up coordinates that reflect the maps' relationships. Thiswill still allow sites to be placed and
located on the map.
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QE To generate a Map File
v
v

1. For convenience, the images to be used for maps should be copied to the Site List folder
specified in MCSetup's Preferences. The default folder isthe User \ Sites folder located where
MTE isinstalled.

2. In MCSetup, select File » Create map.

3. Inthe Open map image dialog box, select an image for the new map. Note the image-type filter
at the bottom. When done, click the OK button.

4, Inthe Map extent dialog box, enter the coordinates for the bounding lines of the map.
Coordinates south of the equator and west of Greenwich are negative.

Map extent (3]

Fleaze enter coordinates in decimal degrees.
Latitudes zouth of the equator and west of
Greenwich are negative.

Map name
Program FilesiMetroCount +3155\U serSites\perth. mpz

Most west longitude: |115.675034
Mozt noth latinde: |-31.723638
Mozt east longitude: |116.151355

Most south latiude: | -32. 218438

| oK |[ Cancel ]

Entering the map's bounding latitude and longitude

5. Click the OK button. A Map File with the same name as the bitmap image, and a .mpz file
extension will be created in the Site Lists folder.

Attaching Maps to a Site List

To display mapsin a Site List, the respective Map Files must first be attached to the Site List. The
Maintain maps dialog box is used to manage the list of maps associated with a Site List.

Haintain maps ®
Map files attached to site list, drag to change order
1z Altach...
MtLawiley. mpz
Meta map name
[ ook [ Cancel ]

Attaching maps

Note that the itemsin the list have a descending priority (the top of the list has the highest priority).
When locating sites, if the area of two or more maps intersect, the map with the higher priority will
be displayed.

oE To attach maps to a Site List

" 1. Right-click in thelist pane of a Site List, and select Maintain maps from the pop-up menu.
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2. Inthe Maintain maps dialog box, click the Attach button.
Select one or more Map Files to attach to this Site List, and click the OK button.
4. Reorder the attached maps list as required by dragging the map items.

Note that maps can be disassociated from the Site List selecting, and clicking the Detach
button.

5. Click the OK button to return to the Site List.

Navigating Maps

When placing sites on amap, the target map will first need to be selected from the list of attached
maps, and displayed. Depending on screen size, the target map may need to panned and scrolled to
locate the desired position for a site.

w

0& To switch the displayed map
g 1. Right-click inthelist pane of a Site List, and select Maintain maps from the pop-up menu.

2. Select the desired map, and click the OK button. The selected map will be displayed in the map
pane of the Site List.

oE To pan around a map

™ 1. ThePan box dialog box displays a smaller version of the entire map. The rectangle indicates
the area of the map currently being displayed. Click and drag this rectangle to display a new
area of the map.

Pan box ®

[ Cancel H Apply ]

Panning around a map
2. Click the Apply button.

oﬁ To toggle the Site List splitter position
|
v

» Select View » Toggle splitter. Thiswill toggle the orientation of the splitter bar between the list
pane and the map pane.
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Site.Lane | Attribute Site.Lane " Description # |
1

g P g
Stirling %02.0 Stirling Immediately 10-10  Tuscany Wa
HJnz.0 stifing HJnz.0 stifing 5 Immediately  10-10  TuscanyWa
HJo4.0 stiring I - . e

1] >I|_

HJos.0 stifing : | — :
@ EJoe.1 stiding
o6z stifing

v
@ EJov.1 stiding
g

(ST N BT BT,

HJoz.z Stirling

g o s | o=,

Optionally toggle the splitter bar position
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Using the Metamap

The Metamap is intended to be a map that encompasses the other maps attached to a given Site List.
When the Metamap is displayed, the bounding rectangles of each of the attached maps will be
overlaid, assuming the correct coordinates have been entered for each map. Detail maps can be
selected directly from the Metamap.

oﬁ To set the Metamap for a Site List

" 1. Right-click in thelist pane of a Site List, and select Maintain maps from the pop-up menu.
2. Inthe Maintain maps dialog box, click the Metamap button.
3. Select the desired Map File, and click the Open button.
4. Click the OK button to return to the Site List.

03 To display the Metamap

e * Right-click in the map pane of a Site List, and select Show metamap from the pop-up menu.
Note that if you a Metamap has not been designated, this option will be unavailable.

0& To select an attached map from the Metamap

v < With the correct latitude and longitude entered for each map, the Metamap will contain black
rectangles for the bounding area of each of the attached maps. Right-click within arectangle,
and select Find detail map to display that location.

BB stirting3n.sit EE®
Site.Lane | Attri.. | D.. | Start Deb Description ~ — v T = Tt it b

E;Im .0 stirimg 5 Immediately  10-10  Tuscany Way - N of N et |4 4, E E

Jo2.0 string 5 Immediately 10-10  Tuscany Way - 5of — | [ e tecop

%03.0 Stirfing 5 Immediately  10-10  Tuscany Way - 5 of - Each = ha

H@Jo4.0 stiing 5 Immediately 10-10  Lucca Street- S of ¢ ol = — Nl [ T I —

@Jos.0 stiing 5 Immediately  10-10  Lucca Street- S of t o 1 &g HWY

© EJoe.1 stiing 4 MextHouwr  30-30  Hale Road - E of Luc b ’3@1{5 o

© EJoe.z stiing 2 MextHouwr  30-30  Hale Road - E of Luc Sz -
© EJo7.1 stiing 4 MextHour  30-30  Hale Road - W of Pe - B O

@ EJo7.z stiing 2 MextHouwr  30-30  Hale Road - W of Pe :

© EJos.0 string &  MextHour  10-10  Cromarty Road - ' Fereonc | (g L 1

© @Joo.0 stiing &  MextHour 1010 Cromarty Road-Ec . | T B =GR

@ @910.1 Stiring 3 Immediately  30-30  Empire Avenue - Mo "\ {;

@ E;I 10,2 Stirling 1 Immediately  30-30  Empire Avenue - Mo | k 7 N r

@ E;I 11.1 Stirling 3 Immediately  30-30  Empire Avenue - 5 ¢ - ;' — —X \:\ Srp

@ E;I 11.2 Stiring 1 Immediately  30-30  Empire Avenue - 5 ¢ Catims Beach { ]‘\_.—- & }_‘)l % I

@ 5312.1 Stiring 3 Immediately  30-30  Pearson Street - Mo % | N ~ 1 ;ﬁ 7 Y
< > < >

Example Metamap - the bounding rectangles are the attached maps
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Placing Sites on a Map

Each site in a Site List has an associated latitude and longitude for placing and locating the site on a
map. The location of a site can be set in a number of ways:

* Create anew site directly on amap.

« Drag an existing site onto the map.

¢ Manualy enter asite's coordinates.

¢ Use a GPS unit to automatically set a site's coordinates.

Using the first two methods described above, the site's coordinates are derived from the map's
bounding latitude and longitude coordinates.

Using the last two methods where the coordinates are specified, if one of the attached maps contains
these coordinates, MCSetup will automatically display the site on that map.

oE To create a new site on a map

v . 1. Display the map that will contain the new site, and scroll to the desired location.
2. Place the mouse pointer at the precise location, right-click and select New site from the pop-up
menu.

3. Follow the usual procedure for adding a site.

oﬁ To place an existing site on a map
v » 1. Display the map that will contain the existing site, and scroll to the desired location.
2. Inthelist pane, locate the site to be placed on amap.

3. Click-and-drag the site onto the map, dropping it at the precise location. Note that a group of
sites can be selected and dragged to place them at the same location, such as multi-lane sites.

4. Confirm the site location by clicking the OK button. The selected site(s) will appear.

aﬂ To manually enter a site's coordinates
" 1. While creating or editing a site, click the Location button.

2. Enter the coordinatesin the Latitude and Longitude edit boxes. To enter the coordinates using
Universal Transverse Mercator, click the UTM button, and enter the site coordinates using
Eastings, Northings and the UTM zone.
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Site location EI UTH converter,

Location
South and ‘West are negative degrees. UTH location
Deg Min Bew Ellipsoid: | ‘WE584 w
Latitude |-31.917835 | |0 1] Morthing: |0 m
.
Longitude | 115.793066 | |0 1] E asting: |0 m
Zone: |0
GPS - NMEA 0183
UTC time: Cancel ] [ Corvert
GPS zignal quality:
Mumber of satellites in use:
Antenna altitude:
Seconds since lazt differential update:
Differential reference station name:
[ Ok ] [ Cancel ]

Setting the coordinates for a site
3. Click the OK button to update the site's coordinates.

Locating Sites

Using a Site List's attached maps is the simplest method for locating the correct list item for agiven
site. Once a site has been located on a map, M CSetup can automatically select the corresponding item
in the list pane, which can then be easily setup. Conversely, MCSetup can automatically display the
map location for a selected sitein the list pane.

oa To toggle the site highlight

v « Double-click amap, or right-click amap and select Flash sites from the pop-up menu. This
will shade the map to make visualy finding sites easier.

oﬁ To locate a site from a map

v » Locate asite on amap, right-click on top of the site, and select Locate site from the pop-up
menu. The corresponding site will be selected in the list pane. Note that if there are multiple
sites extremely close together at the point selected, all of those sites will be selected in the list
pane.

oﬁ To locate a site's location on a map

o 1. Inthelist pane of a Site Ligt, right-click asite to be located, and select Find on map from the
pop-up menu. If the site can be found within one of the Site List's attached maps, M CSetup will
display that map with the selected site centred in the Map pane. The selected site name will
also be displayed in red.

2. MCSetup will automatically enable the site highlight feature that will shade the map. If
necessary, double-click the map to turn the shading off.
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Data Collection Checklist (MCSetup)

The Checklist feature provides a basic means of tracking the setup and data collection of a group of
sitesin MCSetup. Anicon next to each site indicates the current state of the site. Initialy, the
Checklist icon will be blank. M CSetup will automatically change thisicon when asiteis setup, and
then when the site has been unloaded, and ultimately stopped.

Icon Description
Site has been setup. (Survey started)
" Site has be_en unloadgd, but not stopped.
(Mid-survey inspection)
o Site has been unloaded and stopped. (Survey

complete)

oE To reset the Checklist icon for a group of sites
i 1. InaSiteList'slist pane, Shift or Ctrl select a group of sites.
2. Right-click one of the selected sites, and select Reset states from the pop-up menu.
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Enforce Site List (MCSetup)

The Enforce Site List feature only allows RSUs to be setup from a Site List, by disabling the Setup
and Unload buttons when thereis no Site List open. Enforcing the usage of a Site List ensuresthat a
given siteexistsin a Site List, and that a RSU was setup adhering to that information.

When the Enforce Site List feature is enabled, a Site List must be open to make the Setup button
available. When unloading data from a RSU, MCSetup will attempt to match the RSU's header to a
sitein the currently active Site List. Unloading of the datawill only continue if the siteis found.

= HcSetup
File Wiew Roadside Unit Technical ‘Window Help

I COM1 I Plusz I Single charnel 7 E45127D MCEE-6 [MCE5] (c)Microcam 02403401

=
L=

Use Ctrl {r,5,u,%,c) keys to access toolbar, Alk key to enter menu,

Effect of the Enforce Site List feature

A further option exists to prevent accidental editing of Site Lists. In order to change a Site List this
option must be toggled.

Both options can be found in MCSetup's Preferences.

Preferences 3]

Communications port
|com v|

Falder for site lists and maps
|E:\MTESites |[ Browse... ]

Basze folder for unloaded data
|D:\Program FilezMetroCount +3155U zeriData | [ Browse... ]

Subgroup by...
L “rear “ Monith JL Site “Attributel

Sample: | [unloads] |

Use metric units
Uze long file names

|52 bighespaadynload
Allow editing of site list

Enforce site list use

Enforce Site List option in MCSetup
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