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Overview

Site Lists provide an excellent means of managing the process of collecting data. Using the familiar RSU setup
diaog box, site setup information can be compiled into associated lists. Field setup then only requires connection to a
RSU and selection of asite from a Site List. Thisremoves the need for any manual entry in the field, greatly
improving efficiency and accuracy of setup, especially with Pocket PCs.

Site Lists are created using MCSetup, and can be used in either MCSetLite or MCSetup. Site Listsare stored in a
simple comma-delimited text file, so they can aso be created and edited using a spreadsheset program.
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MCSetLite with a Site List loaded
M CSetup supports afew advanced Site List features not supported by MCSetL ite, including:
» Maps based on bitmap images, with support for common compressed bitmap images.

» Checklist feature for tracking sites that have been setup, and unloaded.
 Site List usage enforcement, to force RSUs to be setup from a Site List.

Note:
& A Site List window in MCSetup is split into two panes, called the List pane and the Map pane. Most Site List
operations are performed by right-clicking in one of the panes. Each pane has a different menu.
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Site List with map in MCSetup - note the right-click menu
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Site List Construction
Creating Site Lists

Newly created Site Lists are stored in the folder specified in MCSetup's Preferences. The default location is the User
\ Sites folder located where MTE isinstalled.

A single Site List may contain thousands of sites, however small groups of related sites per Site List is much more
practical.

aﬂ To create a new Site List
g 1. InMCSetup, select File » New Site List.
2. Inthe New Site List file box, enter afilename.
3. Click the Save button and an empty Site List will be displayed.
Existing Site Lists are opened by selecting File » Open sites.
When a Site List is closed, MCSetup will ask to save any changes.

Editing Sites

Adding sitesto a Site List uses the same dialog box used for RSU setup. The default setup parameters used for the
new site can be copied from an existing site, or copied from the header of a RSU.

oE To add a new site to a Site List
" 1. Right-click in aSite List'slist pane, and select New site.
Right-click on an existing site to use its parameters as a starting point.
2. 'llj'o create anew site from a RSU that has been manually setup, check the Get initial settings from Roadside
nit option.

Hew site list entry.
MNew site entry

Optionally copy fram Roadside unit

The initial values for this new site item can be read from a Roadside Unit directly. Check.
the box below to enable this feature.

[] Get initial settings from Foadside Unit

%

Optionally copy setup parameters from a RSU

3. Click the Next button to display the setup dialog box.
4. Enter the setup parameters per normal RSU setup.
Start times such as Next hour or Next day will be automatically calculated at the time a RSU is setup.
5. When done, click the OK button.
Again per normal setup, each parameter will be range-checked, and warnings displayed if necessary.
The site'sicon indicates the type of Sensor Layout selected.

Icon Description
& Site uses Classifier Layout.
Site uses Count Layout.

0& To edit an existing site
w? 1. Right-click on an existing site, and select Edit site.
2. Edit asrequired, and click OK.
To display aread-only summary of asite, simply double-click.
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Site properties 3]

01-0

Site number - Lane

Site: ‘UT ‘ Attribute |Stlrlmg | LanaE
Latiude -31.924838 | Long [115784872 |
Iritals Spacing
Direction & \5 - South bound 458, North bound BaA. ‘ ‘w | Deb [ms)

Direction B ‘I] - Unused or unknown ‘ ‘m | DebB (ms]

Type ‘Axle sengars - Paired (Class, Speed, Cou‘

Description ‘Tuscany ‘fay - N of Empire Ave ‘

Start time: ‘Immed\atew ‘

Displaying all site parameters

0& To change the start time for a group of sites
g 1. InaSiteList'slist pane, Shift or Ctrl select a group of sites.

2. Right-click on one of the selected sites, and select Set times.
3. Confirm changing the selected sites start time by clicking Yes.
4

In the Roadside Unit Start Time dialog box, select one of the automatically calculated start times. Remember,
the actual time will not be calculated until aRSU is setup.

Roadside Unit Start Time.

Set the time for the Roadside Unit to start. The unit can
be defered for up to ten days.

Start time:

Start on next day

10:04 Thursday, 18 November 2004
Start immediate)

Start on rext hout

Stait on nest day

Start next Monday

Start hewt S aturday

Setting the start time for a group of sites
5. Click OK to apply the new start times.

Spreadsheet Editing

Site Lists comma-separated-values (CSV) format has been designed to provide maximum compatibility with
spreadshest programs. Importing, editing and exporting a Site List through a spreadsheet program should be a
seamless process.

The first column on each row indicates the row type. METAMAP and MAP are used for including map files, DOC for
comments, and SITE for each site. For Site Lists created by M CSetup, a comment row is included above the site rows
to form the column headings when imported into a spreadsheet.

METAMAF, perth. npz

MAF,Churchlands.npz

MAF,MtLawley.upz

DOC,Site,Attrib, Init,Desc,Ln,Dirh,DirE, Mode,State, Spac, StrtTn,Debi,DebB, Lat, Long,
SITE,01,5tirling, RPN, Tuscany Way - N of Empire Ave,0,5,0,0,1,1000,0,10,10,-31.924528,115.784572
SITE,02,5tirling, RPN, Tuscany Way - § of Dolomite Court,0,5,0,1,1,1000,0,10,10,-31.922364,115. 786673
SITE,03,5tirling, RPN, Tuscany Way - § of Memory Place,d,5,0,2,1,1000,0,10,10,-31.920731,115. 786814

Site List CSV format

Each column must adhere to the normal restrictions for that parameter. The following table is a quick-reference.

Column Description
Site & Attrib Site & Attribute - maximum 20 characters.
Init Operator Initials - maximum 3 characters.
Desc Site Description - maximum 70 characters.
Ln Lane Number - number less than 16.

Directions A and B - for Classifier Layout use A only and leave B as zero.
e 0- Unused or unknown.
e 1- North bound, A hit first.
» 2 - East bound, A hit first.
» 3- South bound, A hit first.
e 4 - West bound, A hit first.
» 5- South bound A>B, North bound B>A.
* 6-West bound A>B, East bound B>A.
e 7 - North bound A>B, South bound B>A.
» 8- East bound A>B, West bound B>A.
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Column

Description

Mode

Sensor Layout
» 0- Axle sensors - Paired (Class, Speed, Count)
» 1- Axle sensors - Separate (Count)
* 2- Axle sensors - Split (Count)
» 3- Vehicle sensors - Separate (Count)

State

Checklist state (M CSetup only).
* 0- No state.
e 1- Site setup.
* 2 - Site unloaded.
» 3- Site unloaded and stopped.

Spacing - must be entered in millimetres (mm). Range is 200 - 3050mm.

StrtTm

Start Time.
e 0- Startimmediately.
e 1- Start next hour.
e 2- Start next day.
e 3- Start next Monday.
* 4 - Start next Saturday.

DebA & DebB

Debounce for A and B Sensor - in milliseconds (ms). Recommended is 30 for single lane, 10
for multiple lanes.

Lat & Long

Latitude and Longitude - in degrees. South and West are negative.
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Site List Usage

RSU Setup from a Site List

Using a Site List to setup a RSU is the same as the normal setup process, except the setup parameters are derived
from the Site List, rather than manual entry.

oﬁ To setup a RSU from a Site List with MCSetLite
g 1. OpenaSiteList by selecting Tools » Open Site List from MCSetLite's menu button. Browse for and select a
Site List, and tap the OK button.
2. Select asite by tapping it.
3. With aRSU connected, tap the Setup button.
4, Tap OK to use the selected site. Tapping Gancel will proceed with anormal setup.

Cancel

Setup Roadside Unit with Sike

List itern?

Select '‘Cancel' for manual setup.,

Confirming Site List use
5. The standard setup dialog box is now displayed with the setup parameters from the selected site. Edit any
parameters if necessary.

The Lock Site List option in MCSetLite's Preferences will prevent editing setup parameters at this point. This
featureisto discourage users from changing settings away from those specified in the Site List.

El pescription

Tuscany Way - N of Empire ]

[ Description

/5 |MCSetLite ¢ o uzzos QY| /2 Moserwice o azzoe
Cancel Cancel

Parameter | Value Parameter | Value

El site o1 [ site 01

El Lare [\l [ Lane [\l

[E] Aktribute Stirling Attribute Stirling

[l Sensor La...  Axle sensors - Paired (Classisg | || B Sensor La...  Axle sensors - Paired (Classys
El irection & 5 - South bound A =6, North b | || B Direction A | 5 - South bound A=E, North b
El Debounce  A=10ms, B=10ms [ Debounce | A=10ms, B=10ms

El operatar RPN [ operator | RPN

[El Spacing 1000 mm - 3t 3.4 in Spacing 1000 mm - 5 ft 3.4 in

El start Immediately [ start Tmmediately

Tuscany Way - N of Empire v

4] [

[ [»

4 [

[ D

=B

[=[8

RSU setup from Site List - normal and locked.

6. Tap the OK button to proceed with the setup.
7. Check the RSU's status to confirm the setup.
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1

oﬁ To setup a RSU from a Site List with MCSetup
|
v

w

Open a Site List by selecting File » Open sites . Browse for and select a Site List, and click the Open button.
M CSetup can have more than one Site List open at the same time.

Select asite.

With aRSU connected, click the Setup button.

The selected site's setup parameters will be displayed in aread-only form. Confirm the details and click OK to
proceed with the setup.

Setup, 3]

01-0

Site ‘UT ‘ Attribute |Stlrlmg | LanaE

Latiude -31.924838 | Long [115784872 |

Initals Spacing | 1000 mm - 3163 4in

Direction & ‘5 - South bound 4> B, North bound B34, ‘ ‘w | Deb [ms)

Site number - Lane

Direction B ‘I] - Unused or unknown ‘ ‘m | DebB (ms]

Type ‘Axle sengars - Paired (Class, Speed, Cou‘

Description ‘Tuscany ‘fay - N of Empire Ave ‘

Start time ‘Next Hour ‘

Confirmation of site setup parameters

5. Check the RSU's status to confirm the setup.

RSU Unload from a Site List

When thereis a Site List open in MCSetup, the Unload procedureis slightly different. MCSetup will retrieve the
RSU's header, and attempt to match it to an item in the currently active Site List. Thisisto support MCSetup's Data
Collection Checklist feature.

To unload datafor asite that does not exist in a Site Ligt, firstly close all open Site Lists, and then proceed with the
Unload.

oE To unload data using a Site List

v . 1. Openthe Site List that contains the site that the connected RSU was setup with.
2. Click the Unload button on MCSetup's main toolbar.
3. MCSetup will locate the site in the Site List and start the Unload procedure.
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Maps (MCSetup)

Overview

A map in MCSetup consists of a Map File, which uses a.mpz file extension. This file contains a pointer to the
location of the map's bitmap image, and additional information about the map, such as latitude and longitude.

A SiteList can have several attached maps, with sites distributed across them. Also, a single map can be shared
amongst several Site Lists.

Each Site List can aso have a map designated as the Metamap. Thisis usually alow detail map that encompasses
each of agroup of smaller, high detail maps.

Preparing Maps

Site Lists support maps in the form of bitmap images, including common compressed bitmap formats, such as JPEG.
Such images can be sourced from many locations, including local street directories, or exported from a vector-based

mapping system.

Suitable bitmap images should contain sufficient detail to allow sites to be placed with reasonable accuracy, based on
the screen size where MCSetup will be used. Remember that multiple maps can be associated with each Site Ligt, as
well as alow-detail Metamap.

In order to use a bitmap image, the corresponding Map File must first be generated. A Map File contains a pointer to
the bitmap image for the map, and the latitude and longitude of the bounding rectangle of the map. The Map Fileis
then attached to Site Lists as required.

Note that when generating a Map File, the latitude of the top and bottom boundaries, and the longitude of the left and
right boundaries of the image will be beneficial. These coordinates are used for a number of purposes:

« Assigning coordinates to sites placed on amap.

» Locating sites on amap.

« Displaying the bounding rectangles of each attached map on the Metamap.

 Locating and placing sites using a GPS unit.
If the bounding coordinate information is not available, it is still possible to use mapsin Site Lists, however the

functionality listed above may be limited. Alternatively, for adjoining maps, simply make up coordinates that reflect
the maps' relationships. Thiswill still allow sites to be placed and located on the map.
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1. For convenience, the images to be used for maps should be copied to the Site List folder specified in
MCSetup's Preferences. The default folder isthe User \ Sites folder located where MTE isinstalled.

2. In MCSetup, select File » Create map.

3. Inthe Open map image dialog box, select an image for the new map. Note the image-type filter at the bottom.
When done, click the 0K button.

4. Inthe Map extent dialog box, enter the coordinates for the bounding lines of the map.
Coordinates south of the equator and west of Greenwich are negative.

Hap extent 3]

Please enter coordinates in decimal dearees.
Latitudes south of the equator and west of
Greenwich are negative.

oﬁ To generate a Map File
v
v

tap name
Program FilestMetroCaunt w315\ serSitesiperth. mpz

Most west longitude:
Most north titucs
Most east langitude:
Most south titucs

Entering the map's bounding latitude and longitude

5. Click the 0K button. A Map File with the same name as the bitmap image, and a.mpz file extension will be
created in the Site Lists folder.

Attaching Maps to a Site List

To display mapsin a Site List, the respective Map Files must first be attached to the Site List. The Maintain maps
dialog box is used to manage the list of maps associated with a Site List.

Maintain maps ®

Map files attached to site list, drag to change order

1z
L awley.mpz

Meta map name
perth mpz ‘ [ Meta map I

Attaching maps

Note that the itemsin the list have a descending priority (the top of the list has the highest priority). When locating
sites, if the area of two or more maps intersect, the map with the higher priority will be displayed.

0& To attach maps to a Site List
= 1. Right-click inthelist pane of a Site List, and select Maintain maps from the pop-up menu.
2. Inthe Maintain maps dialog box, click the Attach button.
3. Select one or more Map Filesto attach to this Site List, and click the OK button.
4. Reorder the attached maps list as required by dragging the map items.
Note that maps can be disassociated from the Site List selecting, and clicking the Detach button.
5. Click the 0K button to return to the Site List.

Navigating Maps
When placing sites on amap, the target map will first need to be selected from the list of attached maps, and

displayed. Depending on screen size, the target map may need to panned and scrolled to locate the desired position
for asite.

oE To switch the displayed map
e 1. Right-click inthelist pane of a Site List, and select Maintain maps from the pop-up menu.
2. Select the desired map, and click the OK button. The selected map will be displayed in the map pane of the Site
List.

oﬁ To pan around a map
g 1. ThePan box dialog box displays a smaller version of the entire map. The rectangle indicates the area of the
map currently being displayed. Click and drag this rectangle to display a new area of the map.
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Pan box

B

Panning around a map
2. Click the Apply button.

aﬁ To toggle the Site List splitter position
L
]

« Select View » Toggle splitter. Thiswill toggle the orientation of the splitter bar between the list pane and the
map pane.

B! stirtingan.sit
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.1 Stirling
.2 Stirling
.1 Stirling
.2 Stirling
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Using the Metamap

The Metamap is intended to be a map that encompasses the other maps attached to a given Site List. When the
Metamap is displayed, the bounding rectangles of each of the attached maps will be overlaid, assuming the correct
coordinates have been entered for each map. Detail maps can be selected directly from the Metamap.

0& To set the Metamap for a Site List

g 1. Right-click inthelist pane of a Site List, and select Maintain maps from the pop-up menu.
2. Inthe Maintain maps diaog box, click the Metamap button.
3. Select the desired Map File, and click the Open button.
4. Click the OK button to return to the Site List.

03 To display the Metamap

w * Right-click in the map pane of a Site List, and select Show metamap from the pop-up menu. Note that if a
Metamap has not been designated, this option will be unavailable.

0& To select an attached map from the Metamap

v « With the correct latitude and longitude entered for each map, the Metamap will contain black rectangles for the
bounding area of each of the attached maps. Right-click within arectangle, and select Find detail map to
display that location.

BBl stirting3n. st
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W Egom Stiting 4 Mexk Hour 30-30  Hale Road - E of Lu = § & ' gl
@ 9Jo62 Stilng 2 MextHow  30-30  Hale Road-E of Luc Searbeuy a T
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[sen] 931 1.2 Stiring 1 Immediately  30-30  Empire Avenue - 3¢ CatnabpBeach | I‘L . 'r\)! !
[s:n] 9312‘1 Stiring 3 Immediately  30-30  Pearson Street - N ™ ! N p.; Lil ]A > 2 Pl
3 | > < | >

Example Metamap - the bounding rectangles are the attached maps
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Placing Sites on a Map

Each sitein a Site List has an associated latitude and longitude for placing and locating the site on amap. The
location of a site can be set in anumber of ways:

» Create anew site directly on amap.

» Drag an existing site onto the map.

¢ Manualy enter asite's coordinates.

» Use a GPS unit to automatically set a site's coordinates.

Using the first two methods described above, the site's coordinates are derived from the map's bounding latitude and
longitude coordinates.

Using the last two methods where the coordinates are specified, if one of the attached maps contains these
coordinates, MCSetup will automatically display the site on that map.

0& To create a new site on a map

v 1. Display the map that will contain the new site, and scroll to the desired location.
2. Place the mouse pointer at the precise location, right-click and select New site from the pop-up menu.
3. Follow the usua procedure for adding a site.

0& To place an existing site on a map
1. Display the map that will contain the existing site, and scroll to the desired location.
2. Inthelist pane, locate the site to be placed on a map.

3. Click-and-drag the site onto the map, dropping it at the precise location. Note that a group of sites can be
selected and dragged to place them at the same location, such as multi-lane sites.

4. Confirm the site location by clicking the OK button. The selected site(s) will appear.

oﬁ To manually enter a site's coordinates
» 1. While creating or editing a site, click the Location button.

2. Enter the coordinatesin the Latitude and Longitude edit boxes. To enter the coordinates using Universal
Transverse Mercator, click the UTM button, and enter the site coordinates using Eastings, Northings and the
UTM zone.

Site location %] UTH converter 3]
Location
South and ‘West are negative degress. UTh locstion

Deg Min Sec Elipsoid: | WiE584

Latitude ‘-31.91?835 ||u | |D | Northing:

— b ]
Longitide | 115733065 | [0 |[o | Eastng: 0|
e

“
m
m

Zone:
GPS - NMEA 0183

GPS signal quality

Number of satellites in use:

Antenna altitude:

Seconds since last differential update:

Ditferential reference station name:
Take reading

Setting the coordinates for a site
3. Click the OK button to update the site's coordinates.

Locating Sites

Using a Site List's attached maps is the simplest method for locating the correct list item for agiven site. Once a site
has been located on a map, MCSetup can automatically select the corresponding item in the list pane, which can then
be easily setup. Conversely, MCSetup can automatically display the map location for a selected site in the list pane.

03 To toggle the site highlight

o » Double-click amap, or right-click a map and select Flash sites from the pop-up menu. Thiswill shade the map
to make visually finding sites easier.

03 To locate a site from a map

v » Locate asite on amap, right-click on top of the site, and select Locate site from the pop-up menu. The
corresponding site will be selected in the list pane. Note that if there are multiple sites extremely close together
at the point selected, all of those sites will be selected in the list pane.
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oﬁ To locate a site's location on a map

= 1. Inthelist pane of aSite List, right-click asite to be located, and select Find on map from the pop-up menu. If
the site can be found within one of the Site List's attached maps, M CSetup will display that map with the
selected site centred in the Map pane. The selected site name will also be displayed in red.

2. MCSetup will automatically enable the site highlight feature that will shade the map. If necessary, double-click

the map to turn the shading off.

©2013 MetroCount® - MTE User Manual - Ste Lists
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Data Collection Checklist (MCSetup)

The Checklist feature provides a basic means of tracking the setup and data collection of a group of sitesin
MCSetup. An icon next to each site indicates the current state of the site. Initially, the Checklist icon will be blank.
M CSetup will automatically change thisicon when a site is setup, and then when the site has been unloaded, and

ultimately stopped.
Icon Description
Site has been setup. (Survey started)
¢ Site has been unloaded, but not stopped. (Mid-survey
inspection)
@ Site has been unloaded and stopped. (Survey compl ete)
oﬁ To reset the Checklist icon for a group of sites
e 1. InaSiteList'slist pane, Shift or Ctrl select a group of sites.

2. Right-click one of the selected sites, and select Reset states from the pop-up menu.
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Enforce Site List (MCSetup)

The Enforce Site List feature only allows RSUs to be setup from a Site List, by disabling the Setup and Unload
buttons when there is no Site List open. Enforcing the usage of a Site List ensuresthat a given site existsin a Site
List, and that a RSU was setup adhering to that information.

When the Enforce Site List feature is enabled, a Site List must be open to make the Setup button available. When
unloading data from a RSU, M CSetup will attempt to match the RSU's header to a site in the currently active Site
List. Unloading of the datawill only continue if the site is found.

M HCSetup.
File ¥iew Roadside Unit Technical Window Help

fcomt [ Pus | Single channel 7 E45127D' MC56-5 [MCSS] (c)Micranom 02/03/01

Use Chrl (r,5,u, v, c) keys to access toolbar, Alk key to enter menu,

Effect of the Enforce Site List feature

A further option exists to prevent accidental editing of Site Lists. In order to change a Site List this option must be
toggled.

Both options can be found in MCSetup's Preferences.

Preferences 3]

Cammunications part
[com v

Falder for site listz and maps
[EAmTES kes | [ Browse... |

Bage folder for unloaded data
|D:\ProgramFiIes\MelroCounl w315\ sertData | [ Browse. . ]

Subgroup by. .
L ear “ Month JL Site “AttrihuteJ

Sample: |[un\oads] ‘

Use metric urits
Use long file names

152 bighepaadload
Allow editing of site list
Enforce site list use

Enforce Site List option in MCSetup
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